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Advise DDE function
A DDE function issued by a client application that requests DDE server application to supply 
it with the specified data whenever it is updated.



Attaching Toolbox
An operation of fastening the Toolbox to one of the borders of the CorelQUERY window. To 
attach floating Toolbox drag it to the desired border (top, bottom, left or right) until the 
dotted outline of the Toolbox takes the shape of the attached bar along the entire border of 
the window.



Arrow keys
The arrow keys are ¬, , ®, ¯ keys on the numeric keypad. They are used to move around the 
data table with a keyboard. They also move the insertion point in the dialog boxes.



Active window
Active window is the one in which you are working. Its Title bar is highlighted. The next 
action you perform applies to the active window.



BLOB field
The Binary Large Object is one of the Paradox data table fields that may contain the 
extensive amount of information. A BLOB field can contain formatted or unformatted text, 
structured or unstructured binary data including picture and sound objects.



Brightness
In the HSB color model the component that determines the amount of black in a color where 
0% is black and 100% is white. See also Hue and Saturation.



Check box
A square box in a dialog box used to turn options on or off. The option is turned on when "X" 
appears in the check box after clicking on it. The option is off when the check box is empty.



Column
The column is a vertical set of cells in a data table. The cells in the column belong to one 
and the same data field in the data table. The name of the column in the data table is 
identical to the field name.



Column button
The button on the top of the column of cells displayed in the data table window. Clicking on 
the column button lets you easily select the whole column of cells. Clicking again on the 
column button deselects the column.



Command
One of the items of a menu (a word or phrase) that invokes an action.



Control menu
A menu available in all Windows applications. Commands on the menu allow you to 
maximize, minimize, close, move or resize your application. Control menu commands in 
dialog boxes let you move or close them. Pressing the ALT key and SPACEBAR or clicking on 
the box on the left side of the title bar opens the Control menu.
Related Topics
CorelQUERY Control Menu
Data Table Window Control Menu



Cursor
Used to indicate menu command, toolbox button or other screen item. The cursor can be a 
mouse pointer, moved with a mouse, its shape depends on the function the program 
currently performs. The cursor can also be a cell pointer used to point to the current cell with
a keyboard; in this case the cursor is a thick frame outlining the current cell.



Custom topic
One of the topics to establish DDE conversation with CorelQUERY. The custom topic allows to
link to CorelQUERY and have access to a single data table specified as the second parameter
of the INITIATE DDE function. This can be a database filename, a SQL SELECT statement, a 
query file name or the name of a data table window.



Database
Database is a collection of data tables (files) having the same structure. For example, 
Paradox Database contains Paradox data files with .DB extension.



Datasheet
A document for storing and manipulating data. A datasheet is identical to a data table and 
consists of cells arranged in columns and records.



Data range specification
The specification of a range of cells in a data table to perform a CorelQUERY function upon. 
The data range specification is used in the REQUEST DDE function to specify data to be 
requested from a data table opened in CorelQUERY. For example, "ALL:100" specifies all 
fields in the record number 100.



Data source
Data source is a collection of data tables or files pertaining to the particular database 
(Paradox, FoxPro, etc.). When connecting to data table(s) through the ODBC level you should
first specify the data source where the data table(s) are located.



Data table
The data table is a collection of data arranged in columns and rows. When you open a data 
table it is displayed in a data table window. You can open multiple data tables and switch 
from one data table window to another by clicking on it. The data table window then 
becomes active and you can apply any menu command available in the current mode of 
connection to the data source.



Data table window
A window that displays opened data table. There may be multiple data table windows 
currently opened with CorelQUERY.



DDE client
An application that establishes a DDE link to the source data in a document opened by a 
DDE server application in order to have the information updated automatically whenever it 
changes in the source document.



DDE interface
The Dynamic Data Exchange facility provided with Windows that allow a DDE client 
application to request specific data from a DDE server application. Since the DDE link is 
established any changes in the original document are reflected in the destination document.
CorelQUERY is a DDE server that can be accessed through a DDE mechanism by any 
application that supports DDE. Most of the CorelQUERY menu command can be realized 
through the DDE macro functions issued from within a macro in the client application.



DDE server
An application that supplies data from a source document or its part linked to a destination 
document through the DDE interface. CorelQUERY is a DDE server that supports DDE links 
from data tables opened in it to documents in a DDE client application.



Deselect
To cancel the currently active selection of cells, so that no more commands could be applied 
to it. You can deselect the previously selected region of cells by clicking somewhere outside 
it or clicking on the Select All button.



Destination file
A file opened with your client application into which you want to insert or link a portion of 
data from CorelQUERY.



Detaching Toolbox
A process of setting the Toolbox loose, so it may float across the CorelQUERY screen. To 
detach the Toolbox double-click on its background area. After this you can move the Toolbox 
wherever you like, resize it or attach to other borders of the screen.



Drag
To move the mouse while holding down the mouse left button. Releasing the button 
completes the action. With dragging you can easily move data from a cell or displace a 
border of selection.



Double-click
To push the left mouse button twice in quick succession.



Dialog box
A window displayed when additional information is needed to perform an action. For 
example, when you choose Open command from the File menu a dialog box appears 
prompting you to choose the mode of connection to a data source.



Execute command
One of the CorelQUERY commands issued by a client application in a DDE conversation. 
These commands are supplied as parameters of the DDE Execute function to have 
CorelQUERY perform one or several of its menu commands.



Extension
Characters following a period in a filename that identify the type of information in the file. 
The extension .SQL, for example, indicates that the file contains a SQL statement to request 
data from specific data table.



Embedded object
Data from a file created in one application that is inserted into a file in another application. 
The embedded information can be edited from within the application in which it is 
embedded.



Field
One of the separate data items of which consists a record in the data table. Each field 
contains a different kind of information. A field is identical to a column of cells in a data 
table.



Font
A set of characters in a given typeface and point size, for example, 10 points Times Roman. 
Some fonts are also available in different styles such as italic or bold.



Graphic object
A set of data composing graphic image or picture. A graphic object can be contained in a 
data field of a record. For example, binary large object (BLOB) in the Paradox database files 
may be a graphic object.



Grid
A series of evenly spaced horizontal and vertical lines used to outline data cells. You can 
enable or disable this option with the Format/Grid command.



Highlighting
Marking a selection of cells in order to be distinguished from other cells.



Hue
In the HSB color model, hue is the main attribute in a color that distinguishes it from other 
colors. Blue, green and red, for example, are all hues. See also Saturation and Brightness.



Icon
A small graphic symbol that represents minimized data table windows in CorelQUERY.



Initiate DDE function
The function issued by a client application to start a DDE conversation with a server 
application. The name of the DDE server application must be supplied as the first parameter 
of the function, the topic name should be the second parameter.



Insertion point
A vertical bar that indicates where the text will be inserted when you type it. The insertion 
point appears when you click on a text box in dialog boxes that require you to type 
information.



Linked object
A reference or place holder for data inserted into a destination file. Changes to information 
comprising the linked object are automatically reflected in the destination files.



List box
A box that appears in dialog boxes and displays a choice of options. If the list cannot 
accommodate all of the options vertical scroll bar appears.



Maximize
To enlarge an application window to full screen size.



MDI application
An application that uses standard Windows Multiple Document Interface. Multiple document 
windows can be simultaneously opened and displayed. CorelQUERY is an MDI application.



Menu
A list of commands that appears when you choose a name in the menu bar. The menu bar 
appears below the Title bar which is at the top of the main CorelQUERY window.



Menu bar
The bar on the top of the window that contains the names of the program menus.



Minimize
To shrink an application window to an icon at the bottom of the screen.



Mode of connection
The way that you choose to connect to the desired data table. There are two ways to 
connect to a data table with CorelQUERY. The first one is direct connection to a database 
(such as Paradox or XBase). The second one is to connect to a database through the ODBC 
interface. The latter mode of connection allows you to use standard SQL queries to access a 
data table.



Multiple selection
A method of making multiple data selection regions in a data table to apply a CorelQUERY 
command.



ODBC
The Open Database Connectivity interface level provided with Microsoft Windows to allow 
universal access to a wide range of existing databases. With the ODBC support you are 
given the possibility to work with your database using SQL statements. You need only to 
have the database registered in the ODBC administrator.



Object Linking and Embedding (OLE)
Mechanism that lets you create documents using information generated by different 
applications and maintain connections to those applications. The documents are updated 
whenever changes to the information are made in the original application. The connection 
allows you to make changes to the information by launching the application that created it 
from within our current application.



OLE client
An application that embeds or links an object into a document opened with that application. 
The original object is supplied with an OLE server application.



OLE server
An application that supplies an OLE client application with the original object to be linked or 
embedded into the destination document opened with the client application.



OLE support
The support for the Object Linking and Embedding mechanism that allows an object from an 
OLE server application to be embedded or linked into a document opened in an OLE client 
application.



Palette
A collection of colors displayed in the Select Color dialog box.



Paradox database file
A collection of data records forming a specifically structured data table. In CorelQUERY a 
Paradox database file can be accessed directly or through the ODBC interface. See also 
mode of connection.



Picture Viewer window
The special window for viewing Paradox graphic objects (in bitmap format) that are 
contained in a structured graphic BLOB field. You can resize the window scaling the picture 
view.



Query
A request issued by a user of CorelQUERY to retrieve a portion of data from the data source 
he is currently connected to. This can be a database file, a table etc. A query can be a SQL 
Query or some other command to fetch data.



Query file
A file that contains a SQL statement which is a query to retrieve certain data from the 
currently opened data table. To issue a SQL query a data table should be accessed through 
the ODBC interface.



Query table
A data table resulting from a query issued to retrieve data from the data source. Query 
tables could be saved in files the default extension of which is *.DSQ



Radio button
A round or diamond shaped button in a dialog box that turns an option on or off. When two 
or more options are available only one can be selected.



Request DDE function
A DDE function that requests DDE server application to provide required data to a client 
application that issues this function.



Record
A set of fields that forms complete data set types for a data table. Each field has a different 
meaning. A record is identical to a data row that consists of data cells (fields).



Row
The row is a horizontal set of cells in a data table. The cells in the row belong to one and the 
same data record in the data table. The number of the row in the data table is identical to 
the record number.



Row button
The button on the right of the row of cells displayed in the data table window. Clicking on 
the row button lets you easily select the whole row of cells. Clicking again on the row button 
deselects the row.



Saturation
In the HSB color model a component that determines the purity or intensity of a color. See 
also Hue and Brightness.



Scroll
To shift the view in a data table window to see portions of data outside the current viewing 
area. CorelQUERY provides scroll bars along the edges of a data table window.



Select
To choose a range of cells in the data table window with mouse or keyboard. The cells 
composing the selection are highlighted.



Select All button
The button on the top left corner of the data table window. Repetitive pressing of the button 
toggles on and off the selection of the whole data table.



Sound object
A set of data composing a file in the sound format. Its contents can be output to a speaker 
with the help of special sound driver. A sound object can be contained in a data field of a 
record. For example, binary large object (BLOB) in the Paradox database files may be a 
sound object.



SQL
Structured Query Language - a standard language used to access and process databases.
SQL provides a set of statements with a predefined syntax used to retrieve and manipulate 
data. Some databases support SQL by themselves (like SQL SERVER). To use SQL with other 
databases you should connect them to the ODBC interface.



SQL query
A SQL statement used to request data from a database. With an SQL query you can't change
data in the data table (update or append records, for example). SELECT * FROM is an 
example of an SQL query.



Status bar
The bar in the bottom of CorelQUERY window that displays helpful information about current 
state of the program.



System topic
One of the topics to establish DDE conversation with CorelQUERY. The system topic allows to 
link to CorelQUERY and have access to multiple data tables through single DDE channel. The
data tables are specified as the second parameter of the INITIATE DDE function. Also the 
System topic provides system services such as help information on the DDE execute 
commands available with CorelQUERY.



Terminate DDE function
The function issued by a client application to end a DDE conversation with a server 
application.



Title bar
The bar across the top of a Windows application that contains control menu box, minimize 
and maximize boxes and the name of application and optionally the name of a file it is 
working with. CorelQUERY data table windows also have the Title bar as well as most dialog 
boxes.



Toggle
To alternately turn a program function on and off. For example, the Grid command from the 
Format menu in CorelQUERY toggles the display of the data table grid on and off.



Toolbox
The bar that contains various buttons with icons on their top duplicating the most commonly
used menu commands. Originally the Toolbox appears on the top of CorelQUERY window, but
you can detach it and move across the screen wherever you like or attach it to other edges 
of the window. You can also resize the Toolbox by dragging its edges.



Topic
The QUERY of services provided with the DDE server application that you want to exchange 
information with. With CorelQUERY two topics are available: system topic and custom topic.



Transaction
The single act of exchanging data in a DDE conversation.



Typeface
Characters of a single design such as Times New Roman of Arial. Most typefaces are 
available in different styles like regular, bold, italic and bold italic.



Window
A rectangular area of the screen in which applications or application documents are 
displayed. Every application window has a Title bar and menu bar across its top and one or 
two scroll bars along the side and/or bottom.



XBase data files
Data files that pertain to one of the following Databases: DBase III, DBase IV, FoxPro.
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Overview
CorelQUERY is a database viewer, that provides a quick and easy way to gather database 
information and build query tables. CorelQUERY can view files from database application 
files which use Microsoft's Open Database Connectivity, such as dBASE, Paradox, FoxPro and 
SQL Server. Once you open a data table you can browse through it viewing its structure and 
contents, sort data in different ways, copy all or a portion of data into your document and 
establish links to it. Another advantage of CorelQUERY is that you need not own a database 
program to view files--all you require is a database file from a third party.
CorelQUERY is designed for viewing specific database files; it can only read data and will not 
modify or corrupt the data file contents. Each data processing operation that deals with data
manipulation concerns only temporary data structures and user-constructed query tables 
destined for current and future use.
Using CorelQUERY, you can query and analyse database files directly from Corel VENTURA 
and CorelCHART. Another advantage of CorelQUERY is that you need not own a database 
program to view files--all you require is CorelQUERY and a database file from a third party.
If CorelQUERY is installed on your system, you are ready to make your first database query. 
To install CorelQUERY, run Corel Setup from the Windows Program Manager (e.g., File, Run 
b:\setup). Consult the CorelDRAW Installation Guide for further details.
See also: 
· Making new data queries 
· Opening data queries
· Adding Data Sources



Clipboard support
Copying selected data from a query table and pasting them into a client application.



DDE support
CorelQUERY supports Dynamic Data Exchange (DDE). You can use DDE to set up links 
between spreadsheet applications and data tables accessed through CorelQUERY.
You can create dynamic links between any application that supports DDE and CorelQUERY. 
When the linkage is established the data appears in the application just as if it had simply 
been copied and pasted. If the source information changes, the data in the application is 
updated automatically.
Notes:    CorelQUERY does not create a dynamic link with the source application unless you 
actually open the server database program and choose Paste Link. If the data in the server 
file has been updated, use CorelQUERY to repeat the query.
DDE links guarantee that you will be presenting updated information in the application. 
CorelQUERY is a DDE server. It provides allows you to execute many commands issued from 
within a client application through a DDE channel. These commands duplicate CorelQUERY's 
main menu commands.



OLE support
CorelQUERY supports the Microsoft Object Linking and Embedding (OLE) mechanism. 
CorelQUERY provides links to different data sources into an application that is used to 
incorporate these data. CorelQUERY acts as an OLE server only, and an application should 
also support OLE to be an OLE client.
Both OLE 1.0 and 2.0 are supported by CorelQUERY. Embedding is not included with 
CorelQUERY; you can only establish links from the destination files in your application to the 
data sources accessible to CorelQUERY.



Managing data queries
CorelQUERY enables you to retrieve data from different data sources which may be various 
database files, tables etc. The retrieved data are combined into a data table known as data 
query. The data queries thus formed can be saved separately in the special format files with 
the .DSQ extension. There may be several new or already made data queries opened at a 
time, each appearing in the separate window.



SQL support
Once connected to a Database through ODBC level you can use Structured Query Language 
statements to make your own queries. To simplify access to a data table you may wish to 
store the most frequently used SQL queries in separate query files. The saved SQL queries 
may be consequently loaded to perform desired action.



Data manipulation
CorelQUERY is designed for viewing specific database files; it can only read data and will not 
modify or corrupt the data file contents. Each data processing operation that deals with data
manipulation concerns only temporary data structures and user-constructed query tables 
destined for current and future use.



 ODBC-based connection
Using the ODBC interface you can access numerous databases and use the powerful 
capabilities of the Structured Query Language (SQL). You don't even need to know the 
nature of the particular database, with the ODBC interface it may be quite transparent to 
you. Once you have entered the ODBC-based connection you can switch through all 
available databases that support ODBC. You need only to install the proper database drivers 
prior to connection.
To connect to existing databases using the ODBC interface:

· Choose ODBC Data Sources.



 CorelQUERY Help Contents
CorelQUERY Help is divided into the seven categories listed below.    To select a category, 
click its icon. 

  

   



 Data Source dialog box
Chooses the data source type and the way to connect to it:
Dialog Box Options
Source Type:

    ODBC Data Sources:
specifies connection to the data sources through the ODBC interface.
Related Topics

New command
Adding Data Sources



 Open Data Query dialog box
Opens an existing data query file and displays it in its own data query window. You can have 
more than one data query file open at a time.
Dialog Box Options

File Name Edit box displays the default file *.DSQ until you type in the name 
of the file you want to open, or select the file name you want 
from the list box. List box contains the list of the files in the 
current directory with the default extension.

Drives Contains the list of all the available disk drives.

Directories Contains the list of all the available directories.

Source Contains the list of all the available database file formats.

ANSI to OEM Switch this option ON if the file you want to open has the OEM 
(DOS) standard.

Related Topics

Open command
Opening data queries



 Save Data Query dialog box
Saves new data query table displayed in the data query window to the specified file.
Dialog Box Options

File Name Edit box displays the default file *.DSQ until you type in the name 
of the file you want to open, or select the file name you want 
from the list box. List box contains the list of files in the current 
directory with the default extension.

Drives Contains the list of all the available disk drives.

Directories Contains the list of all the available directories.

Source Contains the list of all the available data query file formats.

ANSI to OEM Switch this option ON if the file you want to open has the ANSI 
standard.

Related Topics

Save as command



 Selection dialog box
Allows multiple data selection from a keyboard.
Dialog Box Options

Field/Record: Specifies the field name or the record number for the 
columns/rows to be selected (deselected) in the currently open 
data table. Make sure that the field name you type in matches 
the case of the corresponding column name of the data table.

Selection:

Field if turned on enables entering a field name.

Record if turned on enables entering a record number.

Mode:

Select if turned on specifies the single selection mode. The previous 
selection will be discarded.

Add if turned on specifies the multiple selection mode. New data 
field/record or a portion of it will be added to the previous 
selection.

Related Topics

Selection command
Selecting data



 Format Font dialog box
Changes the font face, size, style and color of the data table cells.
Dialog Box Options

Font Lists available fonts installed in your system. Select the name of 
the font you want to be displayed in the data table.

Size Lists all the available sizes (in points) for the font selected in the 
Font list box. Select the size for the font you want to display your
text with. If the proper size is not listed type the appropriate size 
into the text box.

Font Style Lists the available font styles: Bold, Italic, Bold Italic, Regular. 
Choose the desired from the list box.

Strikeout If checked on enables the strikeout effect.

Underline If checked on enables underlining of the text.

Foreground Controls the text color. Invokes the dialog box that helps you 
choose or customize data table colors.

Background Controls the color of the data table background. Invokes the    
dialog box that helps you choose or customize data table colors.

Sample Shows the example of text with the options you set.



 Go To dialog box
Use the Go To command from the Data menu to locate the specific record in the current data
query table.
Dialog Box Options

Record: Specifies the number of the record to move to.
Related Topics

Go To command



 Load SQL Query dialog box
Opens an existing SQL query file and displays it in SQL query window.
Dialog Box Options

File Name Edit box displays the default file *.SQL until you type in the name 
of the file you want to open, or select the file name you want 
from the list box. The list box contains the list of the files in the 
current directory with the default extension.

Drives Contains the list of all the available disk drives.

Directories Contains the list of all the available directories on the currently 
selected drive.

Source Contains the list of available query file formats.

ANSI to OEM Switch this option ON if the file you want to open has the 
OEM(DOS) standard.

Related Topics

Creating and Using SQL statements



 Save SQL Query dialog box
Saves the SQL query statement displayed it in SQL query window to the specified file.
Dialog Box Options

File Name Edit box displays the default file *.SQL until you type in the name 
of the file you want to save or select the file name you want from 
the list box. The list box contains the list of the files in the current
directory with the default extension.

Drives Contains the list of all the available disk drives.

Directories Contains the list of all the available directories.

Source Contains the list of available query file formats.

ANSI to OEM Switch this option ON if you want to save file for the further use 
from DOS applications (i.e., using OEM character table).

Related Topics

Creating and Using SQL statements



     Build SQL Query (ODBC) dialog box
Initial dialog box used to gain access to one of the data tables available in the data source 
chosen to be connected to through the ODBC interface.
Dialog Box Options
SQL Query
Specifies SQL query statement used to process and display a data table.
Build
Builds a new SQL according to the data specified in Select, Order by, and Criteria sections.
Load
Invokes Load SQL Query dialog box to choose a file containing the desired SQL query.
Save
Invokes Save SQL Query dialog box to choose a file to store the newly constructed SQL 
query to.

Note: The SQL Query text box initially displays the default SQL query (SELECT * FROM 
<dataitem>). If you wish to display the whole data item use the default SQL query. 
Choose the proper data item by clicking on it or selecting it with the keyboard arrow 
keys from the List box. The name will be reflected in the default SQL statement. If 
you don't need the default SQL statement type your own SQL query into the SQL 
Query text box. Press OK to activate the SQL query.

Related Topics

New command



Picture Viewer window
The Picture Viewer window is designed to let user view pictures stored in the Paradox 
databases. To open the window position the data table cursor on the cell marked PICTURE 
and choose the View command from the Data menu or press the tool bar button.
Picture Viewer tool bar:
The Picture Viewer window has its own tool bar which allows you to change the appearance 
of the picture and to select a picture from the database.

Home button Displays the first picture in the selected 
database field

Previous button Displays the previous picture in the 
selected database field

Next button Displays the next picture in the selected 
database field

End button Displays the last picture in the selected 
database field

Stretch mode 
button

When pressed the picture is displayed 
stretched or shrunk to the Picture 
Viewer window size. When the button is 
not pressed window size does not affect 
the size of the displayed picture.

Native size button Restores the actual size of the picture in 
the window

Copy button Copies the picture onto the Windows 
Clipboard

Picture Viewer Control menu:

Stretch to Window When the mode is switched on (the 
check mark is displayed to the left of the
menu command) the picture is 
displayed stretched or shrunk to the 
Picture Viewer window size. When the 
mode is switched off window size does 
not affect the size of the displayed 
picture.

Native size Restores the actual size of the picture in 
the window

Copy Copies the picture onto the Windows 
Clipboard

Note: You can have only one Picture Viewer window open at a time.

Related Topics



View command



 Query Builder dialog box
The dialog box allows you to create or modify SQL query for the data table. The dialog box 
contains the following sections(pages):

Select Allows to select data tables and data table fields for an
SQL query

Criteria Allows to add a criteria to an SQL statement.
Order By Allows to specify the order of sorting.
SQL Allows to build, edit, load, or save SQL query.

Note: The OK button is grayed until a query is specified.
Related Topics

New command



 Select tab (Query Builder dialog box)
    Dialog box

This section allows you to select data tables and fields to include into your SQL query.
Dialog Box Options
Tables
Shows the list of available tables for the selected data source. Double click the table name in
the list box to select or deselect the table. The selected tables are marked with check marks.
Columns
Show the complete list of the fields in the selected tables. Double click the field name to 
select the field.
Heading
Shows how the selected field will be titled in the table window. You can type in the new 
name or leave the name from the database.
Table Type
Switch the options for the table types you want to view in the Tables list box.
Related Topics

Selecting Tables and Fields



 Order by tab (Query Builder dialog box)
    Dialog box

Use the Order by page of the dialog box to specify the order of sorting data for the table you
are creating.
Dialog Box Options
Columns
Lists all the fields in the selected tables. The red arrow to the left of the field name in the list 
box indicates the order of sorting defined for that field. To define an order of sorting select a 
filed and then click the corresponding 
Order
Defines the order of sorting for the selecting field.
Related Topics
Sorting data



 SQL tag (Query Builder dialog box)
    Dialog box

Initial dialog box used to gain access to one of the data tables available in the data source 
chosen to be connected to through the ODBC interface.
Dialog Box Options
SQL Query
Specifies SQL query statement used to process and display a data table.
Build
Builds a new SQL according to the data specified in Select, Order by, and Criteria sections.
Load
Invokes Load SQL Query dialog box to choose a file containing the desired SQL query.
Save
Invokes Save SQL Query dialog box to choose a file to store the newly constructed SQL 
query to.
Related Topics

New command



 Column Width dialog box
The dialog box allows you to specify column width for the data table column.
Type in the column width (in characters) in the text box and click OK.



 Criteria tag (Query Builder dialog box)
    Dialog box

This section of Query Builder dialog box allows to set a criteria for an SQL query you are 
creating.
Dialog Box Options
Field Name
Lists all the fields in the selected data tables. Select a field you want to add criteria for.
Operator
Lists all the available criteria operators.
Value
Specifies the value for the criteria. Type in the value you want to match the field to or click 
the List Values button and then select a value from the list of all the available field values.
And/Or

List Values
Lists all the possible values for the field selected in the Field Name combo box.
Add
Adds a criteria you just constructed to the criteria list.
Remove
Removes the selected criteria from the criteria list.
Related Topics

Defining Selection Criteria



 How to...
Get started with CorelQUERY
Query databases
Add Data Sources
Connect to a database
Select and sort data
Use SQL statements
Save your data query
Transfer data from CorelQUERY



Select and sort data

Selecting data with the mouse
Selecting data with the keyboard
Selecting data tables and fields
Using the Select command
Using the Selection dialog box
Defining selection criteria
Changing sorting order
Defining sorting order
Using the Query Builder dialog box



Transfer data from CorelQUERY
Transferring data using the clipboard
Setting up a DDE link
Dragging data from CorelQUERY
Updating links
Changing links
Canceling links



Use SQL statements
Overview:    SQL support
Saving SQL statements
Loading SQL statements
Selecting data tables and fields
Defining selection criteria
Changing sorting order
Defining sorting order
Build SQL Query (ODBC) dialog box



Save your data query
Save a data query
Save a data query under a new name



To save a data query:
1. Choose the Save command from the File menu. If you are saving a newly created file,

the Save Data Query dialog box appears.

2. Type in the new query file name in the File Name edit box. You may need to change 
the drive and directory, use the Drives and Directories fields for this purpose.

3. Click OK or press <Enter> to save current data query in a file.



To save a data query under a new name:
1. Choose the Save As command from the File menu. The Save Data Query dialog box 

appears.

2. Type in the new query file name in the File Name edit box. You may need to change 
the drive and directory, use the Drives and Directories fields for this purpose.

3. Click OK or press <Enter> to save current data query in a file.



Connecting to a database using ODBC
Using the ODBC interface you can access to as many databases as it provides. You don't 
even need to know the nature of the particular database, with the ODBC interface it may be 
quite transparent to you. Once you have established the ODBC based connection you can 
switch through all available databases that support ODBC. You need only to install the proper
database drivers prior to connection. Consult your ODBC administrator for the installation 
procedure details.

To establish connection to a data source through ODBC:

1. Choose the New command from the File menu or click the New button on the Toolbox.

2. In the Data Source dialog box that appears choose the ODBC Data Sources item and 
double click on it or press the OK button. The item will expand to show the data 
sources available at the moment. Select the appropriate data source and double click
on it or press OK.

3. Build an SQL query in the Query Builder dialog box.

The necessary data table will show up in the new data query window.

See also Using SQL statements



Overview:    Selecting and sorting data
You can select a single table cell, a column, a row or an arbitrary combination of the above 
items. The data are selected and automatically adjusted to form a regular data structure, 
that is to say, the fields selected from one record have their counterparts selected from the 
other selected records. In other words, the number and types of the fields selected from 
different records are always the same no matter how much fields and of what types you 
have selected from each of the records (the corresponding non selected fields from other 
records that have some fields already marked, are selected automatically). This allows the 
user to make multiple record selections of identical contents (size and types of fields), so it 
would be possible to copy them to the corresponding rectangular portion of cells in your 
application (for example, a spreadsheet table).

Note:    The cell in your application table marked as current, becomes the top left corner cell
of a rectangle for the rectangular selection imported from CorelQUERY.



Selecting data with the keyboard
1. Use the arrow keys to move the cell cursor to the desired cell. The selected cell 

becomes highlighted.

2. Hold down the Shift key while moving the cursor with arrow keys to make a selection.

Note: Moving this way across the selected rows or columns deselects them.

Adding data to the selection

To add some more data to your selection hold down the Ctrl key, then hold down the Shift 
key and move the cursor to make successive selection. The corresponding data columns and
rows will be added to the previous selection to form a regular structure of fixed size records.

Note:    If you press the Shift key on one of the selected cells while holding down the Ctrl key
the entire column and row intersecting on the cell will be deselected.



Using the Selection dialog box
Using the Selection dialog box to select data

You can as well make appropriate column or row selection using the Selection dialog box 
which is invoked choosing the Selection command from the Edit menu. 

1. To select a row press the Record radio button in the Selection group and type the 
record (row) number into the Record text box.

2. To select a column press the Field radio button and type the field (column) name into 
the same text box which this time changes its name to Field.

Note:    The field name is case sensitive. Make sure the Field name matches the case 
of the column name in the data query window.

If you wish to start a new selection press the Select radio button from the Mode group. 
Otherwise press the Add radio button to enhance your previous selection. Press OK to make 
current selection. To deselect cells from a column or row use the same dialog box indicating 
the required field or record name in the text box.

See also Selecting data with the mouse



Selecting data with the mouse
To make data selection using a mouse move the mouse cursor into the desired data query 
window. The cursor takes the shape of a hand with a small rectangle under the index finger. 
Position the rectangle on the desired cell and click the mouse left button. The cell becomes 
highlighted and the corresponding row and column buttons are pressed automatically.

To select a range of cells position the cursor on the top left cell of a rectangle to be selected, 
hold down the left button of the mouse and drag the cursor to the bottom right cell of your 
selection, then depress the button. As you drag the cursor the cells are being highlighted to 
form the selection rectangle. You may as well select continuous portion of columns or rows 
dragging the mouse cursor across the column or row buttons. If you drag the cursor 
backwards the corresponding columns or rows will be successively deselected.

Click the Select (Deselect) All button to apply the action to the whole data table.

Adding data to the selection

Hold down the Ctrl key while dragging the cursor to make successive selection. The 
corresponding data columns and rows will be added to the previous selection to form a 
regular structure of fixed size records. If you click on one of the selected cells holding down 
the Ctrl key the entire column and row intersecting on the cell will be deselected. You may 
select or deselect entire columns or rows leaving the rest of the selection intact. To do this 
hold down the Ctrl key and click on the desired column or row button.

Note: Any time you wish to modify your selection hold down the Ctrl key first.

See also Selecting data with the keyboard



Changing sorting order
You may change the way your data table is sorted by changing an SQL query in the Query 
Builder dialog box.

To change the order of sorting in the data table:

1. Choose the SQL command from the Data menu. The Query Builder dialog box 
appears.

2. To change the order of sorting you can either change your SQL query by hand in the 
SQL Query edit box, or create a new SQL query.



Defining sorting order
To define sorting order in an SQL query:

1. Select the Order by section of the dialog box. The Columns list box shows you the 
complete list of fields in the selected tables.

2. Select the field you want to sort your table by.

3. In the Order by group select an order of sorting for the selected field. The field icons 
in the left part of the Columns list box shows you the selected order of sorting.



Overview:    SQL support
SQL support provides an interface to database information. When you use the ODBC 
support, you are given the possibility to work with your database using SQL statements. 
These are reduced only to the queries, you can't use data definition or manipulation 
statements which are also part of the SQL syntax but are intended to modify the contents of 
a database which is prohibited by CorelQUERY. The SQL is supported by the ODBC interface. 
You can create or change SQL query in the Query Builder dialog box which appears 
automatically after establishing connection to the data source and is available during the 
whole CorelQUERY session through the SQL command from the Data menu.



Saving SQL statements
1. Click on the Save button, the Save SQL Query dialog box appears.

2. Choose the desired drive, directory and file name and press the OK button. The SQL 
query will be saved into a file the default extension of which is .SQL.



Loading SQL statements
1. Press or click the Load button and choose the appropriate SQL file name, directory 

and drive in the Load SQL Query dialog box.

2. click OK and the contents of the SQL file will be loaded into the SQL Query text box.



Transferring data using the clipboard
The Windows clipboard is a temporary storage area used to transfer text and graphics 
between Windows applications.

To copy data from CorelQUERY to another application using the Clipboard:

1. Select the data area you want to copy.

2. Choose Copy from the Edit menu.

3. Open other application into which you want the data to be copied.

4. Choose Paste from the Edit menu.

See also Copy command



Setting up a DDE link
To set up a DDE link from a Windows application that supports this type of linking:

1. Open the appropriate data query table.

2. Select the area of cells in the data query table you'd like to link to.

3. Choose Copy command from the Edit menu.

4. Switch to the client application.

5. Place the cursor at the place in the destination file of the client application where you
want the linked data to begin.

6. Choose Paste Link command from the Edit menu.

Note:    After setting up dynamic link between client and CorelQUERY and saving the 
worksheet or document, each time you open the file the link to CorelQUERY is 
reestablished and the most current information is copied into the file.



Dragging data from CorelQUERY
To copy data from CorelQUERY using drag and drop option the OLE client application must 
support object linking and embedding (OLE 2.0).

Note:    Dragging data between applications is different from using the Copy command on 
the Edit menu because the data you copy is not placed on the Clipboard. Once you've 
dragged data to another application, you can't use the Paste command to paste another 
copy of the data.

To copy data from CorelQUERY into another application:

1. Arrange CorelQUERY and the target application so that the data query window with 
data to be linked and the destination file window are both visible.

2. In CorelQUERY select the data you want to link.

3. Position the mouse cursor on one of the edges of the selection until the cursor takes 
the shape of a hand with an arrow under the index finger.

4. Hold down the Ctrl key and then hold down the left button of the mouse. Drag the 
cursor holding down the Ctrl key to the desired application window.

Note:    The mouse cursor takes the shape of a crossed circle while being dragged to 
the target application indicating screen areas where data insertion is prohibited.

5. Position the mouse cursor on the destination file window in the place you want to 
insert the selected data to. Release mouse button and Ctrl key. As you drag the 
cursor over the destination file window the cursor takes the shape of a document 
indicating the region where the data insertion is permitted. The CorelQUERY icon 
appears in your destination file marking the link to the data query you have created.

Note:    If you drag the selected data without holding the Ctrl key the data will still be 
copied but the link will not be established.

Double clicking on the CorelQUERY icon in the target application results in starting 
CorelQUERY (if not yet started) and displaying the data query window with the source data 
selection linked to your application. The data table window becomes active.



Updating links
Updating links to the source data is performed by an OLE client application. Since 
CorelQUERY functions only as an OLE server your application is in charge of updating links. 
Thus the method of updating links depends on the application you are currently using to add
source data to a destination file. Refer to the documentation on OLE processing supplied 
with your application.



Changing links
Once a link to a portion of data source is created you may wish to change the currently 
created link to point to a different selection of data. 

To change a link to a data selection:

1. Start your application and open the destination file that contains link to the desired 
data source.

2. Double-click on the CorelQUERY icon that marks the link. The CorelQUERY data query 
window appears displaying data selection associated with the link.

3. In the CorelQUERY data query window modify the current data selection or make a 
new one.

4. Choose Close command from the File menu or double click on the system menu 
button of the data query window to close it. The link to the new data selection will be 
established.



Canceling links
If an OLE client application permits, you can cancel specific link in the destination file so that
the information is no longer updated and remains intact since the last update before the link
is canceled.

You may as well close the link by selecting the corresponding CorelQUERY icon and 
performing the Delete command from the Edit menu in the client application. In this case 
the link will be canceled and the source data disappear from the destination file.



Defining selection criteria
SQL criteria allows you to include into your data query table only those records which meet 
the specified conditions.

To define SQL criteria:

1. Choose the SQL command from the Data menu. The Query Builder dialog box 
appears.

2. Select the Criteria section of the dialog box.

3. From the Field Name combo box select the field for which you want to specify a 
criteria.

4. Select the criteria operator.

5. In the Value box type the value you want to be used in the criteria. Alternatively you 
may first click the List Values button and then choose the value from the combo-
box.

6. Select And option if you want both the existing criteria and the new one to be true. 
Select Or option if you want either the existing criteria or the new one to be true.

7. Click Add button to add the new criteria to the criteria list. You may delete the 
existing criteria from the criteria list by selecting a criteria and pressing Remove 
button.



Selecting data tables and fields
To select tables and fields:

1. Choose the SQL command from the Data menu. The Query Builder dialog box 
appears.

2. Select the Select section of the dialog box.

3. In the Type group box select the data types you want to view. The Tables list box 
contains the list of the available data tables. Select the tables you want to use in your
SQL query. To select or deselect a table double click on the table name in the listbox 
or position a cursor on the table name and press a spacebar. The selected tables are 
marked with a check mark on the table icon.

4. From the Columns list box select the fields you want to view in the data query 
window. You may also define a column heading for the selected field by changing the 
default name in the Heading box.





 Menu Commands
Click the various menu areas of the graphic below for information about CorelQUERY's 
menus.





Quick List
The Quick List records in order the last four files you have opened. To open a file using the 
quick list, choose it from the menu, either by number on the keyboard or with the mouse.











Tile Command
Automatically and neatly arranges open data query windows on screen



Cascade
Arranges open windows diagonally, leaving title bars visible. 



Arrange
Arranges icons for all minimized windows.



Close All
Closes all data query windows



Window Menu Quick List
If two or more data query windows are open, you may select them by number or by clicking 
their menu item from the Window Menu Quick List.





Contents
Displays Help contents



Search
Opens the Help Search text box. Key in words or parts of words on various subjects. They will
appear in the Search Go To box. Double clicking the subject opens a Help topic for that area.



About
Opens the About CorelQUERY box, citing the application version number, copyright, user 
name and serial number and available disk space.





Restore
Restores the active data query window or CorelQUERY window to its former size and 
location.



Move
Displays a four-headed arrow you can use to reposition the active data query window, 
CorelQUERY window, or an open dialog box.



Size
Displays a four-headed arrow you can use to change the size of the active data query 
window or CorelQUERY window.



Minimize
Shrinks the active data query window or CorelQUERY window to an icon.



Maximize
Enlarges the active data query window or CorelQUERY window to fill the available space.



Close
Closes the active data query window or an open dialog box. Quits CorelQUERY.



Switch To... (CorelQUERY Control Menu only)
Lists all currently open applications and activates the one you select.



Run... (CorelQUERY Control Menu only)
Opens the application you select.



Next (Data table window Control menu only)
Switches to the next CorelQUERY data query window.



New command (File menu)
The command allows you to connect to a data source and to create a new data query. You 
can connect to a Data Base table through the Microsoft Open Data Base Connectivity (ODBC)
interface in which case you should install ODBC package before starting CorelQUERY. When 
you select a data source and specify a query CorelQUERY adds a new window to your 
desktop so you can have several data query windows open at a time.

To connect to a data source:

1. Choose the New command from the File menu. The Data Source dialog box appears allowing 
you to select the type of data source you want to connect to.

2. From the list box select the ODBC data source.

3. Follow the instructions for the subsequent dialog boxes to make a query and create a new data 
query table.

See also Save As command, and ODBC based connections



New button
Allows you to connect to a data source and to create a new data query.

See New command



Open command (File menu)
The command allows you to open an existing data query from a file on disk.

To open a data query:

1. Choose the Open command from the File menu or press the tool bar button. The Open Data 
Query dialog box appears.

2. Select the data query file name from the File Name list box or type the name in the edit window. 
You may need to change the drive and directory, use the Drives and Directories fields for this 
purpose.

3. Click OK or press <Enter> to open the selected query file. CorelQUERY will load the query file 
and display data in the newly opened data query window.

See also New command and Save command



Open button
The command allows you to open an existing data query from a file on disk.

See Open command



Save command (File menu)
Saves changed data query to the file on disk. If you choose the command for the newly 
created data query CorelQUERY will ask you for the query file name.

See also New command and Save As command



Save As command (File menu)
Saves the newly created or changed data query to the file on disk.

To save a data query under a new name:

1. Choose the Save As command from the File menu or press the tool bar button. The Save Data 
Query dialog box appears.

2. Type in the new query file name in the File Name edit box. You may need to change the drive 
and directory, use the Drives and Directories fields for this purpose.

3. Click OK or press <Enter> to save current data query in a file.

See also New command and Save command



Close command (File menu)
Closes the active data query (table) window.

If you have several windows open and want to close only one of them, switch to the window you want to 
close, and then use the Close command from the File menu.



Close button
Closes the active data query (table) window.

If you have several windows open and want to close only one of them, switch to the window you want to 
close, and then use the Close button or Close command from the File menu.



Exit command (File menu)
Ends your CorelQUERY work session.

If you have opened any data table window, you'll be asked if you really want to exit CorelQUERY.



Copy command (Edit Menu)
Puts a copy of a selection onto the Windows Clipboard. The selection can be a cell, cell range
or the whole data query table.

See also Selection command



Copy button
Puts a copy of a selection onto the Windows Clipboard. The selection can be a cell, cell range
or the whole data query table.

See also Selection command



Selection command (Edit Menu)
Displays the Selection dialog box so you can control which cells are to be selected on the 
data table window.

These settings affect only the active data query window.

To select or deselect a row or column:

1. Choose the Selection command from the Edit menu.

2. In the Selection group box check Field radio button if you want to select a table column, check 
the Record radio button if you want to select a row.

3. In the Mode group box check the radio button for the selection mode you need. You have the 
alternative to select a new area or to add an area to the current selection.

4. In the local edit box type either field name or the record number.

Using this command you can as well deselect the previously selected rows and/or columns.

See also Selecting data



Column Width command (Edit menu)
Sets the column width for the selected column. You specify the column width in characters 
so the real width of columns depends on a selected font.

To change the column width:

1. Position the data table cursor on a cell of a column you want to change.

2. Choose the Column Width command from the Edit menu. The Column Width dialog box appears.

3. Type in the new column width (in characters) and click the OK button.

Note:    You can change the width of only one column at a time.



Grid command (Format menu)
Toggles the displaying of gridlines in the data query window.



Grid button
Toggles the displaying of gridlines in the data query window.



Font command (Format Menu)
This command allows you to change the font format for the whole data query table. When 
you choose the Font command from the Format menu the Font dialog box appears to let you 
select the necessary font face, size, style and color. This command also lets you select the 
background color for the whole table.

To change font face, size, style or color:

1. Choose Font from the Format menu or press the button on the tool bar.

2. From the Font combo box select the font face you want.

3. From the Font Style combo box select the font style.

4. From the Size combo box select the font size(in points).

5. If you want your text to be displayed strikeout or underlined switch the appropriate check-boxes in
the Effects group.

6. Use the Foreground and Background buttons to change the color of data table text and 
background. These buttons call the Select Color dialog box.

Note: The Sample field lets you control the font you select.



Font button
This button allows you to change the font format for the whole data query table. When you 
choose the Font button or Font command from the Format menu the Font dialog box appears
to let you select the necessary font face, size, style and color. This command also lets you 
select the background color for the whole table.



Go To command (Data Menu)
Displays the Go To dialog box, which allows you to position the record pointer on a specific 
record in the data query window. This is a shortcut for moving in a very large data range.

To move to the specific record in your data query table:

1. Choose Goto command from the Data menu or press the appropriate button on the tool bar.

2. In the Record field enter the record number you want to move to.



Go To button
Displays the Go To dialog box, which allows you to position the record pointer on a specific 
record in the data query window. This is a shortcut for moving in a very large data range.



View command (Data menu)
The command allows you to view binary objects such as pictures or sounds stored in the 
Paradox data bases. In the data query window such objects are represented with 
corresponding names:

PICTURE Windows bitmap

SOUND Windows sound file

To view a picture from a data query table:

1. Position the data table cursor on the cell marked PICTURE.

2. Choose View from the Data menu or click the tool bar button. The Picture Viewer window appears
showing you the selected picture. You can use the Picture Viewer window tool bar or control 
menu to change the appearance of the displayed picture or to select the other picture from the 
data table.

3. To close the Picture Viewer window choose the View command once more or depress the tool bar
button.

To play the sound from the data query table:

1. Position the data table cursor on the cell marked SOUND.

2. Choose View command from the Data menu or click the tool bar button. The current data cell 
sound will begin to play. 

Note: Wait until the sound stops playing because at this time the mouse and 
keyboard inputs are disabled.



SQL command (Data Menu)
The command allows to modify currently active data query table by performing specific SQL 
query. Changing current SQL query you can change the order of sorting and toggle the 
displaying of data table fields and records.

To change SQL query:

1. Choose the SQL command from the Data menu. The Query Builder dialog box appears.

2. To change an existing SQL query edit SQL statement by hand in the SQL Query box.

3. To create a new SQL query apply to the Select, Criteria, and Order by pages of the dialog box to 
specify the new selection, criteria, and order of sorting, and then switch to the SQL page and 
press Build button.

Notes:

1. If you wish to keep the SQL statements for the further use you may save them in a separate file. 
Click on the Save button, the Save SQL Query dialog box appears. Choose the desired drive, 
directory and file name and press the OK button. The SQL query will be saved into a file the 
default extension of which is .SQL.

2. After you have build SQL query you are not able to edit with the help of Select, Criteria, and Order
by sections of the dialog box.

See also Using and creating SQL statements



SQL button
This button allows to modify currently active data query table by performing specific SQL 
query. Changing current SQL query you can change the order of sorting and toggle the 
displaying of data table fields and records.

See also Using and creating SQL statements



 CorelQUERY Screen
Click any part of the screen below for information about what that area does.



Menu bar

CorelQUERY's Menu bar contains six drop-down menus, along with the Windows-standard 
maximize, minimize and control menus.

See also Menus



 Data Table Window Control Menu
Data table window Control menu allows you to execute some general operations with the 
window. Double click on the Control menu icon to close the data table window.

Data table Control menu commands:

Restore Restores the active data table window or to its 
former size and location.

Move Allows to move data table window from a 
keyboard.

Size Allows to change size of a document table 
window from a keyboard.

Minimize Shrinks the active data table window to an 
icon.

Maximize Enlarges the data table window to fill the 
CorelQUERY workspace.

Close Closes the data table window.

Next Switches to the next CorelQUERY data table 
window.



Data Table Window Minimize Button

Minimizes a data table window to the icon at the bottom of the application window 
workspace.



Data Table Window Maximize Button

Maximizes a data table window to the size of the screen.



Data Table Window Icon

Double click the icon to restore window to its original size, or click the icon to open the 
window Control menu.



Data Table Window Title bar

Title bar displays the name of the open document.

Drag the window title bar with a mouse to change the window position.



Status Bar Message Field

The field displays the current state of CorelQUERY.

While moving through the main menu this field gives a short description of the selected 
command.



NUM Field 

Indicates the state of Num Lock key.



CAPS Field - indicates the state of Caps Lock key.



Select/Deselect All Button

Selects/Deselects the whole data table.



Field Button

Displays the name of the data table field.

Click to select/deselect the whole data table column.



Record Button

Displays the number of the data table record.

Click to select/deselect the whole data table row.



Selected Record Button

The pressed record button means that the record contains selected fields. Press the record 
button to deselect all the record selected fields.



Data Table Selection

An area of data table displayed in inverted colors. When you choose Copy command from 
the Edit menu the selected area is copying onto Windows Clipboard.



Selected Field Button

The pressed field button means that the field contains selected records. Press the field 
button to deselect all the selected records.



Active Cell

The data table cell marked with a thick border is an active cell. You can make the cell active 
using the arrow keys or clicking on it with a mouse. You can select/deselect an active cell 
pressing SHIFT key or clicking it with a mouse.





Shortcuts
Menu command keys
Dialog box keys
Movement keys
Selection keys
Window keys



Menu command keys
 Key(s) Command

CTRL+N New (File menu)

CTRL+O Open (File menu)

CTRL+S Save (File menu)

CTRL+C Copy (Edit menu)

CTRL+G Grid on/off    (Format menu)

CTRL+Q SQL Query (Data menu)

CTRL+V View object (Data menu)



Dialog box keys
 Press Function

Tab Moves to next list box, text box, check box, command button or 
group of option buttons

Shift+Tab Moves to previous list box, text box, checkbox, command button 
or group of option buttons

Arrow Keys Moves and selects within active group of option buttons

Spacebar Turns on or off active check box or chooses active command 
button

Letter Keys Moves to next item beginning with that letter in an active list box

Alt+Underlined letter Selects item with the underlined letter

Enter Chooses active command button

Esc Cancels command and closes dialog box



Movement keys
 Movement keys Function

Right Arrow Moves the cursor one cell right

Left Arrow Moves the cursor one cell left

Up Arrow Moves the cursor one cell up

Down Arrow Moves the cursor one cell down

CTRL+PgUp Moves the table one column left

CTRL+PgDn Moves the table one column right

CTRL+Home Moves the cursor to the beginning of the row

CTRL+End Moves the cursor to the end of the row

PgUp Moves the table one screen up

PgDn Moves the table one screen down

Home Moves to the beginning of the table

End Moves to the end of the table



Selection keys
 Selection keys Function

Shift Marks the cell

Shift+Right Arrow Marks the cell to the right if not yet selected, unmarks the cell if 
selected previously

Shift+Left Arrow Marks the cell to the left if not yet selected, unmarks the cell if 
selected previously

Shift+Up Arrow Marks the cell one row up if not yet selected, unmarks the cell if 
selected previously

Shift+Down Arrow Marks the cell one row down if not yet selected, unmarks the cell 
if selected previously

CTRL+Shift For a cell marked within selection region, unmarks the 
intersecting portions of row and column cells; for an unmarked 
cell, marks the intersecting portions of row and column cells

CTRL+Shift+
(Up/Down)Arrow For a cell marked within selection region, 
unmarks the currently selected portion of row cells; for an 
unmarked cell, marks the unselected portion of row cells

CTRL+Shift+
(Left/Right)Arrow For a cell marked within selection region, 
unmarks the currently selected portion of column cells; for an 
unmarked cell, marks the unselected portion of column cells



Window keys
 Window keys Function

ALT+SPACEBAR Opens the Control menu for an application window.

ALT+Hyphen Opens the Control menu for a document window.

ALT+F4 Closes an application window.

CTRL+F4 Closes a document window.

ALT+Esc Switches to the next application window or minimized icon, 
including full-screen programs.

ALT+TAB Switches to the next application window, restoring applications 
that are running as icons.

ALT+ENTER Switches a non-Windows application between running in a window
and running full screen.

DIRECTION key Moves a window when you have chosen Move from the Control 
menu or changes the size of a window when you have chosen 
Size from the Control menu.



Querying databases
Making new data queries
Opening data queries
Adding Data Sources

See also: 
· Corel VENTURA Online Help
· CorelCHART Online Help
· ODBC Help



Making new data queries
1. Choose new from the File menu. The Data Source dialog box appears. 
2. Double-click the ODBC folder. A list of available data sources will appear (see 

also Adding Data Sources).
3. Double-click a data source.

A CorelQUERY window and the Query Builder dialog box open.
4. In the Relations list box, double-click the data table(s) you want to use. Note:    

Until you are familiar with making complex queries, we recommend that you 
select only one table for each query.

5. In the Fields list box, double-click the data fields you want to include in your 
query.

6. Select Criteria and Order/Group choices as required. For example, if you want to 
change the sort order from Ascending to Descending, click the Order/Group tab, 
select the relevant fields, and click Descending.

7. Click the SQL tab and click Build. 
CorelQUERY automatically writes your query in Structured Query Language.

8. Click OK. CorelQUERY generates a query table in a small application window.
If you want to save your query file, choose Save Copy As... from the File Menu 
and give your query table a name. 
The .dsq extension is automatically appended.



Adding Data Sources
The Add ODBC Data Source dialog box appears when you click the Add button in 
CorelQUERY's Data Source dialog box.
To add an ODBC Data Source:
1. Choose a driver name (e.g., dBase Files (*.dbf)) from the Add ODBC Data Source 

dialog box.
2. Click OK.

When the resulting dialog box appears, key in the required data source 
information, i.e., name, version, number or location.



Adding Data Sources
The Add ODBC Data Source dialog box appears when you click the Add button in 
CorelQUERY's Data Source dialog box.
To add an ODBC Data Source:
1. Choose a driver name (e.g., dBase Files (*.dbf)) from the Add ODBC Data Source 

dialog box.
2. Click OK.

When the resulting dialog box appears, key in the required data source 
information, i.e., name, version, number or location.



Opening data queries
1. Click Open... from the File menu.
4. Choose any .dsq file from the Open Query dialog box and click OK. 

The data will flow into a CorelQUERY window.



Opening data queries
1. Click Open... from the File menu.
4. Choose any .dsq file from the Open Query dialog box and click OK. 

The data will flow into a CorelQUERY window.





System Info dialog box
Use System Info to display information about your system, display, network, printing, Corel 
EXEs & dlls and system DLLs.

Dialog Box Options

Choose a category Choose a category from the drop-down list box. The categories are: 
System, Display, network, printing, Corel EXEs and DLLs and 
system DLLs.

List box Displays the system information for the chosen category.
System: information about your computer. For example, Windows 
version, DOS version, processor, etcetera.
Display: information about your monitor. For example, driver, driver
version, etcetera.
Network: information about the network. For example, drivers, 
whether a network is installed, etcetera.
Printing: information about installed printers.
Corel EXEs and DLLs: lists all of the Corel EXEs and DLLs.
System DLLs: lists all of the system DLLs.

Save Saves all of the selected category's details to a predefined file.




